Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Acer Aspire E5-575(G) BIOS unl...
Last Post: quitoshi
Today 01:48 PM
» Replies: 128
» Views: 39430
[REQUEST] HP 17-bs036ur F.24 Advanced/Po...
Last Post: AL_Hedgehog
Today 01:42 PM
» Replies: 1
» Views: 156
[Request] Thunderobot Zero
Last Post: siz-off
Today 12:56 PM
» Replies: 64
» Views: 7353
[Request] Lenovo g40-30 (80fy) whitelist...
Last Post: Chimuelo
Today 12:35 PM
» Replies: 11
» Views: 1551
[REQUEST] ASUS ROG GL504GM BIOS unlock
Last Post: Cone
Today 12:08 PM
» Replies: 5
» Views: 138
[REQUEST] Asus Vivobook X412FLC BIOS Unl...
Last Post: genius239
Today 11:47 AM
» Replies: 5
» Views: 654
Gigabyte Aorus 17X YB Bios Unlock reques...
Last Post: nimkay99
Today 11:43 AM
» Replies: 14
» Views: 1823
Asus ROG GL504GW bios overclock unlock.
Last Post: gasparax
Today 10:21 AM
» Replies: 8
» Views: 1584
[REQUEST] Sony Vaio SVE141 & SVE151 seri...
Last Post: Maxinator500
Today 08:22 AM
» Replies: 42
» Views: 11923
[REQUEST] Lenovo X270 (R0IETxxW) Whiteli...
Last Post: Dudu2002
Today 06:55 AM
» Replies: 5
» Views: 535
[REQUEST] Lenovo Ideapad S510p (89CNxxWW...
Last Post: Dudu2002
Today 04:59 AM
» Replies: 195
» Views: 40926
[REQUEST] Lenovo Yoga 2 Pro (76CNxxWW) W...
Last Post: Dudu2002
Today 03:20 AM
» Replies: 1018
» Views: 261633
[REQUEST] Acer Predator Helios 300 PH315...
Last Post: Dudu2002
Today 03:18 AM
» Replies: 13
» Views: 2629
[REQUEST] Lenovo V580(c) (H1ETxxWW) Whit...
Last Post: nustersen
Today 02:28 AM
» Replies: 622
» Views: 103003
[REQUEST] Acer Aspire VN7-791(G) BIOS Un...
Last Post: Dudu2002
Yesterday 04:59 PM
» Replies: 94
» Views: 56344
[REQUEST] Lenovo B50-70 (9DCNxxWW) White...
Last Post: Dudu2002
Yesterday 02:54 PM
» Replies: 188
» Views: 38468
[Request] zen+ support for ASUS GL702ZC
Last Post: Roland83
Yesterday 11:44 AM
» Replies: 0
» Views: 90
[REQUEST] Asus IPIBL-LB Bios Unlock
Last Post: davidep99
Yesterday 05:03 AM
» Replies: 27
» Views: 23687
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: Dudu2002
Yesterday 03:43 AM
» Replies: 1826
» Views: 264156
[REQUEST] Asus EX-B250-V7 unhide iGPU co...
Last Post: genius239
Yesterday 01:07 AM
» Replies: 44
» Views: 4022

BIOS unlock request for Acer Aspire 5100 v.3.13
#1
Hello,

I'd like to request a BIOS function improvement on an Acer Aspire 5100 laptop please. I'd like to be able to enable AMD-V hardware virtualization and AMD NX data execution prevention on the AMD MK-36 processor. The chip is capable, but the functions in the Acer Phoenix BIOS have been disabled.

   

I've tried searching this board, and tried a couple modified BIOS files, but none give this functionality. I've also tried PhoenixBiosEditor and symcmos, but I'm not versed well enough in BIOS editing to make it do what I want.

Acer BIOS v.3.13 file link:

http://global-download.acer.com/GDFiles/...ER&SC=PA_7

Acer Aspire 5100 BIOS download page:

http://support.acer.com/us/en/product/de...modelId=44


Thanks,
Jeff
find
quote
#2
Hi Jeff ,

To get the AMD NX data execution prevention enabled in your bios , you should knew the register which will be modified for this function and the bit will be modified as well ........ there is no option will be available for this function but you should knew the register and modify it manually .
Also , i will look into your bios to see if there is any options needs unlocking .

Thank you
Ahmed


"Many of life's failures are people who did not realize how close they were to success when they gave up." Smile
find
quote
#3
Hello Ahmed,

So to make sure I understand you correctly, it's not possible to have an option in the BIOS to set the AMD-V and NX bits in the processor? To do so I would have to upload a modified BIOS that has the settings in it?

Seeing as I have no idea how to identify those bits, or to modify the BIOS, this sounds like a lost cause.

Thanks for your help, I appreciate it.

Jeff

find
quote
#4
Hi Jeff ,

The virtualization option is normally hidden and can be unlocked easily and this is called unlocking hidden options and can be done without any problems .
but there are special options like setting the cpu instructions and modifying setting which require setting bit x in register xx to 0 or 1 , this is called a register mode and we need to download the CPU datasheet then search for the register which is responsible for this option and knew the bit which will be modified and search for this register in bios modules and analyse its routine then modifying this routine to set the bit to 0 or 1 .


"Many of life's failures are people who did not realize how close they were to success when they gave up." Smile
find
quote
#5
Hi Ahmed,

I'm glad you think that's easy, because I sure have no idea how to do it! In the BIOS of the many Dell computers I have the two things I'm looking for are easy to find, although called different things because they're Intel chipsets.

It sounds like this is pretty complicated to get working correctly, and I don't want you to waste your time on it unless you just want to. I'm happy to test anything you want me to, as this is a spare old laptop and I don't care if gets broken.

I've looked for the "CPU datasheet" for the AMD Turion 64 MK-36 on AMD's website and in Google, and didn't find anything like what you're looking for. Maybe you have other sources or references though.


Thanks again,
Jeff
find
quote
#6
Hi.
If you do succeed in unlocking the "Advanced" menu, i would like to try to, as i would too like a modified bios for the aspire 5100...
Another option i'm looking for is the the memory remap feature (or "SW Mem Hole Remap" as it is called in PBE).
find
quote
#7
Here is the unlocked bios with the advanced Tab unlocked an all options inside it :-


.rar   mod.rar (Size: 738.63 KB / Downloads: 493)

for the SW MEM REMAP feature its enabled by default and i`m sorry as i unlocked the bios before reading your reply ....... let me knew if you want to disable it or you want to have it as an option to control sothat i modify the modified bios again Smile
try it and i`m waiting your reply .


"Many of life's failures are people who did not realize how close they were to success when they gave up." Smile
find
quote
#8
Thanks, I'll try it and see if it has the options I need.


Jeff
find
quote
#9
You are welcome , please leave your feedback after trying the modified bios to let me knew if it works or not Smile


"Many of life's failures are people who did not realize how close they were to success when they gave up." Smile
find
quote
#10
Okay, I tried it. The "Advanced Chipset Control" did show up, but neither of the Processor options I was looking for were in there.

Thanks for trying.


Jeff
find
quote


Forum Jump:


Users browsing this thread: 2 Guest(s)